Please ensure Javascript is enabled for purposes of website accessibility be_ixf;ym_202407 d_23; ct_100
PRC-Saltillo Logo
PRC Logo
Saltillo Logo
Realize Language Logo
ExploreAAC Logo
AAC Language Lab Logo
AAC And Autism Logo
ALP for AAC Logo
Touch Chat App Logo
LAMP Words for Life Logo
Dialogue AAC App
AAC Funding
AAC Learning Journey
AAC Group Coaching
PRC-Saltillo Store
Minspeak Academy
https://auth.prc-saltillo.com/v1/authorize?response_type=code&redirect_uri=https%3A%2F%2Fprentrom.com%2Flogin&client_id=prentrom&nonce=97952c3071c32507560aba4c8c9859d6&state=872f0b5a8a8e3fc6b50e0b7990bdbd04&scope=openid+profile+email+admin+address+phone+admin+user+title Create New Account

We only use strictly necessary cookies for this website. Please see the privacy policy for more information.   

Our websites will be undergoing scheduled maintenance on July 30th from 8:00 PM to 11:00PM Eastern Time. During this period, services will be unavailable. We apologize for any inconvenience and appreciate your understanding.

An issue has been identified that is preventing Empower software from loading on Accent devices. Read more for detailed instructions for how to fix your device. We sincerely apologize for any inconvenience this may have caused.

An Important Message Regarding iOS Support

Posted Jun 24, 2020 - 9:58am

PRC will discontinue support for iOS 9 & iOS 10 starting with the 2.26 release coming in July 2020.

Why?

With every release, we ensure that new features can be used by supported iOS versions (currently iOS 9-13). As technology advances rapidly, it is increasingly difficult to ensure compatibility with out-of-date iOS versions. In order to provide our iOS customers with the best LAMP Words for Life app experience, we’ve decided to discontinue support for iOS 9 & iOS 10.

Anything I need to do?

We advise our iOS users running iOS 9 or 10 to upgrade to a higher iOS version, ideally the latest version. By doing this you'll gain access to all the latest updates and features - giving you the best LAMP Words for Life app experience!

What are the new minimum supported iOS devices?

The minimum requirement for iOS devices supported by LAMP Words for Life is iOS version 11.0 or later.

What if my device doesn't support iOS 11?

If your device doesn't support any of the newer iOS versions, you should know that:

  • You can still use or download LAMP Words for Life app version 2.25.0 and will be able to continue to use that even after July 2020; however:
    • You will not be able to update beyond 2.25. Therefore, new features introduced after that will not be available on devices running iOS 9 or 10.

Questions? Visit our Support site to contact us via email, phone, Live Chat or online.



News and Updates



Copyright © PRC-Saltillo. All Rights Reserved.