ECO, Vantage Lite, and Vanguard Module 1 - Where Do I Begin? (Software Versions)

  Return to List

In this lesson you will learn how to check the current software version in your device.

You are not required to update your software for this training as long as the Software versions for the ECO is 1.06 and above and the Vantage Lite/Vanguard is 5.02 and above.

It is, however, always good to keep up with software updates. If you have an older version, please check for updates on the PRC web site.

http://www.prentrom.com/support/eco/downloads



Product Training

Learn to operate and customize your device or app


Implementation Classes

Use and integrate your device in school or at home

On Demand Classes

Interactive self-study

Events

Find PRC at an event near you

Copyright © Prentke Romich Company. All Rights Reserved.